Author Topic: Strange electrical problems  (Read 1134 times)

0 Members and 1 Guest are viewing this topic.

Sinfull

  • Newbie
  • *
  • Posts: 1
  • Gender: Male
  • Hi There!
Strange electrical problems
« on: 05 October, 2019, 08:54:15 PM »
Hi all,

I have a w11 avenir with qr20 and car trans.  Just brought the car knowing is had a dash issue. Can I get some opinions on what the issue might be.

So I have all my dash lights IE. Engine check, park brake etc. However no gauges and no cut gear indicator in the middle.
Also my central locking is no not working correctly either.  It won't lock any doors, next thingbitll only do drivers door.

Today I jumped in, hooked up analyser and turned key on. For some reason dash started working. There were a couple of faults relating to speed sensor or something similar.erased them and they havnt come back.
I took car for good drive and everything worked as it should.
I stopped the car, jumped out and tested central locking. All working great.
Started car went for another drive, stopped car went and locked it but central locking wasn't going again.  Jumped back in started car and dash stopped working also.
Strange.

Can anyone tell me if the central locking and dash are linked somehow, ie through the nats system or something.

Any advice is welcome.

Thanks Mat.



Mathuw

  • Newbie
  • *
  • Posts: 2
  • Gender: Male
  • Hi There!
Re: Strange electrical problems
« Reply #1 on: 19 October, 2019, 10:48:09 AM »
Check earths for the central locking on the door or if the earth for the central locking goes into the dash, could be corroded earth under the dash causing your problems. if they are just take the earth off and sand the contacts, bolt and the place where the bolt bolts into. if the earths seem fine could be an issue with relay earthing