Author Topic: P10 idle problem need help ASAP  (Read 1270 times)

0 Members and 1 Guest are viewing this topic.

MISS.VE

  • Unpaid Subs Members
  • Newbie
  • *
  • Posts: 13
  • Gender: Female
P10 idle problem need help ASAP
« on: 16 April, 2015, 10:23:10 AM »
So my P10 has been sitting in the garage for a while due to prepping for a wof, and i tried to turn it on the other day and it was ticking over as flat battery so i got a brand new battery and now it turns on but it wont hold revs, as soon as it goes under 1000revs it turns off any idea how to fix it?

Half of my exhaust is off due to getting it welded atm and i was told that could be the cause due to no back pressure, or my kill switch. Happened to anyone else? only have a week to fix it

THANK YOU IN ADVANCE :)

PS i think i have added this to the wrong thread please tell me if i have



My real name is Lance

  • Afroboltski/Lance
  • NZPPCC Paid Member
  • Forum Lurker
  • *****
  • Posts: 478
  • Gender: Male
  • Air goes in, witchcraft happens, the car breaks
Re: P10 idle problem need help ASAP
« Reply #1 on: 16 April, 2015, 10:48:04 AM »
Did you remove your intake at all? Check for unmetered air problems (vacuum leak, intake manifold gasket, intake piping leak, etc.)

Check fuel pump operation.

Check battery voltage (engine off and running) to confirm alternator performance.

Check voltage going to fuel pump.

Reset ECU again (leave battery off overnight).

Etc.

Quote from: Cameron
Darryl, what would it take to RWD SR convert my QG18 bluebird? Ive got a mate with a angle grinder and stick welder, surely it cant be too hard

ElMatto

  • NZPPCC Paid Member
  • Forum Lurker
  • *****
  • Posts: 368
  • Gender: Male
Re: P10 idle problem need help ASAP
« Reply #2 on: 19 April, 2015, 03:00:12 PM »
Either you'd have air getting in after your MAF, or your idle air control valve needs adjusting
Current: Black B14 Autech, Silver P11 (roller rocker sr18de automatic fury!)
Ex: 2x P10 primera te, sr20ve VZR